[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GRUB problem

cr said:

>> I've concluded that there must be something fairly basic wrong with my bios
settings or maybe the MBR  (though I did run bios autodetect before I started
all this and made sure the alternatives I selected gave the same
drive/head/sector numbers as the labels on the hard drives did).
I'm not sure what tools there are for investigating MBR settings or drive
Meanwhile, boot floppies work (though the Debian one is awfully slow  ;)
============quote from original post

[The details - I installed GRUB in accordance with
/usr/share/doc/grub/README.Debian -
1.  grub-install --root-directory=boot  /dev/hda
2.  Ran  update-grub


titleDebian GNU/Linux, kernel 2.2.20-idepci
kernel     /vmlinuz-2.2.20-idepci root=/dev/hda1 ro

cr, it looks like /boot is available from both /etc/fstab and from your df
listing.  I am assuming that you ran 'update-grub' first to produce menu.lst,
but even if you hadn't done that, by now you have rerun grub-install enough.

I notice that 1. has --root-directory=boot. That should be
--root-directory=/boot according to the README.Debian file.

The other thing to check is in your menu.lst
It says:
kernel     /vmlinuz-2.2.20-idepci root=/dev/hda1 ro

Is that where that kernel is or is it /boot/vmlinuz-2...  ?

I think that /vmlinuz is a symlink to /boot/vmlinuz-2...; so /vmlinuz might
work, but I don't think what you have will work unless that is actually what
is in / .

Unfortunately my /boot is on my root partition here where I just tried this
myself.  If you think that your MBR settings, whatever those are, might be
messed up, you could try installing grub on a floppy.  I just did that on my

First I ran update-grub after installing grub on the system.  I edited
/boot/grub/menu.lst which had root(hd0,0) to make it (hd0,2) since it is on
/dev/hda3.  The rest of it seemed fine.

Then I ran 'grub-install /dev/fd0' with a floppy in the drive.  So you would
do 'grub-install --root-directory=/boot /dev/fd0' I think.


Reply to: