[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GRUB problem

On Friday 27 June 2003 04:28, Anita Lewis wrote:

> cr, it looks like /boot is available from both /etc/fstab and from your df
> listing.  I am assuming that you ran 'update-grub' first to produce
> menu.lst, but even if you hadn't done that, by now you have rerun
> grub-install enough.
> I notice that 1. has --root-directory=boot. That should be
> --root-directory=/boot according to the README.Debian file.

So it should.   I'm fairly sure I typed it in correctly in practice.   I just 
misquoted in my email.

> The other thing to check is in your menu.lst
> It says:
> kernel     /vmlinuz-2.2.20-idepci root=/dev/hda1 ro
> Is that where that kernel is or is it /boot/vmlinuz-2...  ?
> I think that /vmlinuz is a symlink to /boot/vmlinuz-2...; so /vmlinuz might
> work, but I don't think what you have will work unless that is actually
> what is in / .

Well, in my system,  /vmlinuz is a symlink thus:
lrwxrwxrwx    1 root     root           26 Jun 12 08:25 vmlinuz -> 

and /boot/vmlinuz is:
-rw-r--r--    1 root     root       665509 Jun 21 23:05 vmlinuz-2.2.20-idepci

As I read it, my  menu.lst which is as follows:

title  Debian GNU/Linux, kernel 2.2.20-idepci
root  (hd0,0)
kernel     /vmlinuz-2.2.20-idepci  root=/dev/hda1 ro

first sets root to  (hd0,0)      (i.e. /dev/hda1   or  /boot)   
then tries to load   vmlinuz-2.2.20-idepci , passing it the parameters 
of "root=/dev/hda1"

So if the parameters are wrong, it shouldn't matter until after vmlinuz is 
loaded.   My impression of the boot sequence is that Grub stage 1 (in the 
MBR) loads stage 1.5, which loads stage 2, which loads vmlinuz.   And my 
system doesn't seem to be getting any further than stage 1.5 or so.

Hmmm, I suppose it's loading the *right* stage1_5?   /boot/boot/grub is full 
of ???_stage1_5's that install-grub copied there; the one it wants is 
e2fs_stage1_5.    If it loaded the wrong one it certainly wouldn't be able to 
find the next file in the process.    OTOH I just copied  e2fs_stage1_5 as 
stage1_5      - but it made no difference.

> Unfortunately my /boot is on my root partition here where I just tried this
> myself.  If you think that your MBR settings, whatever those are, might be
> messed up, you could try installing grub on a floppy.  I just did that on
> my system.

I'm pretty hazy about the nuts and bolts of what goes in the MBR, I must 

> First I ran update-grub after installing grub on the system.  I edited
> /boot/grub/menu.lst which had root(hd0,0) to make it (hd0,2) since it is on
> /dev/hda3.  The rest of it seemed fine.

Hmmm, update-grub rewrote menu.lst as 
root  (hd0,0)
kernel   /vmlinuz-2.2.20-idepci   root=/dev/hda5  ro

I left that unchanged

> Then I ran 'grub-install /dev/fd0' with a floppy in the drive.  So you
> would do 'grub-install --root-directory=/boot /dev/fd0' I think.

Yes, I did that.  It produced a floppy which, when booted off, just says 
'GRUB' and hangs.

I think I'll see if there's a Grub-specific list I can pursue this on.  
Meanwhile I have a few other Debian things to straighten out....   

Thanks everybody


Reply to: