[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Solved: XFS quotas won't turn on

OK, got it - the newer XFS patches don't use that syntax anymore. You
now need to pass "rootflags=quota" at the boot prompt. 

At least it wasn't all that obvious - the new syntax doesn't seem to
mentioned anywhere besides the XFS mailing lists.


Todd Pytel <tppytel@sophrosune.org> wrote:

> Running Woody with a vanilla 2.4.20 kernel + SGI XFS patch. I've used
> quotas before, but not with XFS. So maybe I'm missing something...
> The man pages say that to activate quotas on a root XFS filesystem,
> you simply do "quotaon -v /".  But if I do that, I get "quotaon:
> quotactl() on /dev/hda1: function not implemented".  I have XFS quotas
> configured in the kernel, and they are reported in dmesg.  The help
> for that option says that generic CONFIG_QUOTA support is not
> required, but I've tried that too. The mount man page claims that
> "quota" is a valid xfs mount option, but remounts fail with a bad
> option error.  I also tried rebuilding the quota package from the
> source deb.  Same deal.
> I must be missing something obvious...
> --Todd

Reply to: