[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Hi All,
I've een banging my head against the following all morning. Basically I'm
trying to get php4-gd2 to be able to use the imageellipse()

Now I've compiled from source, installed other binaries etc... but I just
can't get it working

root@dandylogic:~# dpkg -l php4-gd2
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err:
||/ Name           Version        Description
ii  php4-gd2       4.2.1-4        GD module (with GD2) for php4
root@dandylogic:~# dpkg -l  | grep -i gd
ii  klogd          1.4.1-10       Kernel Logging Daemon
ii  libgd-ruby     0.7.4-3        An extension library to use gd graphics
ii  libgd1         1.8.4-17.woody GD Graphics Library
rc  libgd1-xpm     1.8.4-32       GD Graphics Library
ii  libgd2         2.0.12-1       GD Graphics Library version 2
ii  libgd2-xpm     2.0.12-1       GD Graphics Library version 2
ii  libgd2-xpm-dev 2.0.12-1       GD Graphics Library version 2
(development v
ii  libgdbmg1      1.7.3-27       GNU dbm database routines (runtime
ii  php4-gd2       4.2.1-4        GD module (with GD2) for php4

Now I've check the sorce package and it is for gd 2.0.12 but I'm getting
the following error

Warning: imageellipse(): requires GD 2.0 or later in /var/www/test.php on
line 31

But phpinfo() shows

GD Version
2.0 or higher

Has anyone seen anything like this?

www: http://www.65535.net       | Hosting - Shell Accounts
MSNM: support@65535.net		| Virtual Servers from just $15/mo
e: rghf@65535.net               | Community: http://www.65535.org
t: +44 (0) 7092016595           | Rate us: http://www.65535.net/rate.php

Reply to: