[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: php4-gd2

> On Fri, 2003-05-02 at 01:02, Andrew Pritchard wrote:
> > I've been trying unsuccessfully to get the gd graphics library working
on my
> > 'testing' box. I did apt-get install php4-gd as suggested by others on
> > list previously, but it doesn't appear to work. I checked the apache log
> > file and found this:
> >
> > PHP Warning:  Unable to load dynamic library
> > '/usr/lib/php4/20020429/gd.so' - /usr/lib/php4/20020429/gd.so: cannot
> > shared object file: No such file or directory in Unknown on line 0
> >
> > Not surprising it can't find it - for some reason the gd.so file is in
> > /usr/lib/php4/20010901.
> >
> > How do I correct this? Has anyone else come across the same problem?
> > tried Googling, but no results helped
> Well, I can't really help you on getting it to the right place, but you
> should have a php.ini file somewhere (probably /etc, but I can't be
> certain since I don't use the debian package), do a search in that for
> gd.so and set the path to the right one.
> Jon

There are two php.ini files - under /etc/php4/apache and /etc/php4/cgi
and the installation of php4-gd adds the extensions in. However there is
in that ini file where it specifies the path for the extensions.

Anyone else with any helpful suggestions?


Reply to: