[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Accessing vfat fs as normal user

ajlewis2@intac.com wrote:

In linux.debian.user, you wrote:
Hi Craig,

Thanks for the quick reply.  I've tried various settings in fstab to change
permissions, so far no luck.
This is my latest entry for /dev/sdb (firewire drive):

/dev/sdb    /firewire  vfat     suid,uid=1000,gid=0, rw,noauto,      0    0


Don Nash

Now I can't seem to access any of my dos partitions as user, only as
root. I have tried changing permissions as root using chmod for
these partitions with no luck. I have no problem accessing  my native
linux partitions.  Not shown in the fstab is my firewire drive , which

I'm using sort of the opposite with uid=0 and a gid that my users are
members of.  I would get rid of the space in the options and the comma at
the end.

/dev/hda1    /winc   vfat   rw,uid=0,gid=20,umask=002 0 0

The puzzle is that it sounds like this was working prior to the upgrade of
the system to unstable.  Is that correct?  I'm using Woody and have this
mounting when the system boots.
Here's what I have for my zip drive which is also vfat.  This is to mount it
as needed and it is working for my users.

/dev/sda4	/mnt/zip	vfat	 user,exec,dev,suid,rw,noauto 0  0

Its been a while but the last itme I checked you had to reboot to amke the new permissions work.


BTW - forgive me if this message appears formatted wrong.I am fighting mozilla snapshot at the moment.

Reply to: