[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SOLVED]Re: new kernel, now no network (2.4.20 kernel dhclient)

Another "doh" moment ...

Brian Walker wrote:
Well, it is a week since I had almost the exact same problem (thanks guys for the advice ...) but still striving to get connected using the 2.4.20 kernel ...

First "doh" was not having downloaded the pcmcia-cs package. Having done
that, and fakeroot make-kpkg --append-to-version kernel_image
modules_image, I still could not get the network up. (No such file in /var/run/dhclient.eth0.pid)

On booting, the high tone signal said my PCMCIA card had been accepted, ifup revealed a problem with the socket: protocol not available. Looking at /var/log/daemon.log confirmed the problem lay with dhclient.

Next "doh" moment ... pump -i eth0 ... and problems solved. I suppose I could also have tried dhcpcd (apt-get install dhcpcd removes pump ...) or manually configured with ifconfig ... for anyone else out there with similar problems HTH


Brian F. Walker
Registered Linux User 270078
Debian GNU/Linux

Reply to: