[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Frame buffer support for GeForce 4 Ti4600?


Does anyone know how to get frame buffer support to work on a GeForce 4
Ti4600 card? I have recently switched computers, and in my old computer
vesafb (in a 2.2 kernel) worked just fine with my old GeForce 2MX, but
neither vesafb nor rivafb (in 2.4.20) works with my new card. Does
anyone know how to get it running? I want to run the frame buffer in
800×600 to get 100×40 text (80×25 gives too little text, 132×44 is too

vesafb throws this error message on boot (I tried several VESA modes,
and they all give the same message):

  vesafb: abort, cannot ioremap video memory 0x8000000 @ 0xd0000000

and fails to show anything (the computer boots up into X just fine,
though). Rivafb doesn't warn me, AFAICT, but I couldn't get it working
with "video=rivafb:800x600-256". I might be using the wrong command
line for rivafb, it's poorly documented.

X works just fine with nVidias Linux drivers (I cannot use the XFree86
drivers, on Woody they do not support my card), but I want a working
console mode as well.

Please Cc replies to me, due to the volume I do not read this list.
Peter - http://www.softwolves.pp.se/
  I do not read or respond to mail with HTML attachments.

Reply to: