[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sometimes getting sound fine under woody, but not with xine

This one time, at band camp, Lloyd Zusman said:
> "nate" <debian-user@aphroland.org> writes:
> > Lloyd Zusman said:
> >
> >>   audio_oss_out: Opening audio device...
> >>   audio_oss_out: using device >/dev/dsp1<
> >>   audio_oss_out: opening audio device /dev/dsp1 failed:
> >>   No such device
> >>   load_plugins: audio output plugin
> >>     /usr/lib/xine/plugins/xineplug_ao_out_oss.so:
> >>     init_audio_out_plugin failed.
> >>   main: the specified audio driver 'oss' failed
> >
> > while I cannot provide a solution I can say that I too have experienced
> > this. On my IBM thinkpad T20 with 2.2.19, getting xine to work with
> > audio was hell. I never figured out how I got it working since everytime
> > I rebooted the system I had to start from scratch again, maybe I only got
> > it working by blind luck. I upgraded to 2.4.20 a couple weeks ago, ran
> > xine for the first time last night and audio worked perfectly for about
> > 30 seconds then the X server froze(though the audio was still comming through
> > clearly). Haven't tried it other then the one time. I notice your using
> > 2.4.19 now.. perhaps switching to ALSA would help? I tried switching to
> > ALSA and had no luck either under 2.2.19. Though XMMS, mpg123, and games
> > like simcity 3000 worked flawlessly as far as sound goes. never a glitch.
> Thanks for your reply.  At least now I don't feel so alone with this
> problem.
> Actually, I'm using 2.4.20-686-smp (see the "uname -a" entry in my
> original message).  But the same problem has been there for me in
> 2.4.{18,19}-686-smp, as well.
> > perhaps a bug in the driver..or in xine ? I don't recall trying other
> > video players on my laptop, only xine.
> >
> > nate
> Well, since I can hear KDE's startup music, and since mplayer's oss
> driver properly produces sounds for me, I do think that it's somehow a
> driver problem.  But the mystery is whether it's an xine driver problem,
> a kernel driver problem (perhaps mplayer and KDE use their own sound
> drivers which bypass the kernel), or what ...  ???

I don't remember xine's options all that clearly, and I can't check
right now (I'm ssh'ed in in console only mode), but /dev/dsp1 looks
suspicious to me.  Do you have two sound cards, or two audio outs?  I
would try to force xine to send it's audio out to /dev/dsp, where it
will normally be dealt with by the oss wrapper in KDE's arts server.

As for the KDE thing, I think you can disable sound in the control
panel somewhere.

HTH, and sorry I'm not clearer - hopefully it gives you a starting
point, though.

|  Stephen Gran                  | There is no time like the present for   |
|  steve@lobefin.net             | postponing what you ought to be doing.  |
|  http://www.lobefin.net/~steve |                                         |

Attachment: pgpHWFCfo1waT.pgp
Description: PGP signature

Reply to: