[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RE: cups and hpijs driver

 Michael Olds <MikeOlds@pacbell.net> wrote:
>Re: setting up DeskJet 960c as local printer on Woody box
>I have reviewed the cupsomatic perl script situation and this basically
>duplicates the work being done by the custom PPD and the foomatic-bin and
>foomatic-db (at least that's how I understand it). I have also installed
>cupsys-bsd, gv, and qtcups per various sets of instructions. So now I have
>the following installed:
>Still no joy.
>I think the problem is occuring somewhere between the printer as hardware
>which seems to be installed ok, and the various installed packages which
>also seem to be set up ok. It's just that the two are not talking to each
>Except for the fact that this may indicate something else wrong with my
>setup, I'm about to say "Why do I need this?" since the printer off my W2K
>box works fine and I could probably set up this printer on an open USB port
>and have it up and running in two minutes (the little test it did for itself
>looked like a very nice job of printing, better than the multi-function
>OfficeJetT65 I use on the W2K box.)
>1. What would be the best way to get everything print related out of the
>machine to start over? Uninstall all of the above? Anything else?
>2. Can I still be missing something in my kernel?
>3. How do you command-line send a job to the printer? lpr and pdq both give
>me: "command not found". I looked in modutls aliases and inserted the lines:
>alias /dev/printers  lp
>alias /dev/lp0       lp
>alias parport_lowlevel parport_pc
>and rebooted, but that did nothing, so I removed them. My thinking is it is
>something like this that is the problem: no communication between the
>parallel port and the printing drivers.
>4. I tried printing from the Web, no go, but that's no real test as Mozilla
>doesn't do anything for me except see pages (I just installed the browser).
>5. The error message off Nedit has changed, and is now: lpr: unable to print
>file: server-error-service-unavailable

For a command line printjob try this:
echo "This is a test" > /dev/usb/lp0
assuming you have a usb printer. Otherwise, change the /dev/usb/lp0 with the appropriate stuff.

Reply to: