[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: caught in apt conflict with libc6, zlib1g and zlib1g-dev

On Sun, Dec 01, 2002 at 06:48:02AM -0800, Lukas Latz wrote:
> I tried to install Xine (lib-xine and xine-ui) from locally installed
> debian packages (that I downloaded from their site) on my pretty newly
> installed debian Woody. Before doing that, I had changed
> /etc/aps/sources.list from CD to a net URL and got updates from stable
> main contrib non-free.
> Xine wanted higher versions of libc6 zlib1g zlib1g-dev (indirectly,
> because of a lib-png I believe) and I did some apt-get s to meet those
> expectations, which probably was a big mistake. I don't remember
> exactly how, I think through a GUI apt thing, I was able to force
> install some libs.

Debian's package of xine in Woody uses the Woody versions of libc6,
zlib1g, and zlib1g-dev.

> It didn't work out because apparently I had only changed some of those
> libs, so I tried to roll back, got rid of Xine and all references to
> any local stuff in my /etc/aps/sources.list which now reads:
> deb http://http.us.debian.org/debian stable main contrib non-free

Don't forget to include:

  deb http://security.debian.org stable/updates main contrib non-free

Then occasionally do an apt-get update and upgrade any packages that
need it.

> The current situation is that dselect shows these conflicts:
> libc6 V2.2.5-11.2 zlib1g 1:1.1.4-8 (depends on libc6 > 2.3.1-1)
> zlib1g-dev 1.1.4-1 (depends on zlib1g=1:1.1.4-1)

The zlibg version is current for unstable. zlibg-dev is the version in
Woody, and libc6 is the correct version for stable.

> Yet the versions numbers it shows me are all installed version =
> avail. version.  This can't be true, I'm pretty sure the zlib stuff is
> still as it was from my crazy apt-get with override, which I don't
> remember exactly how to do.
> Because of the depency conflicts, I can't apt-get -u upgrade.
> apt-get install zlib1g tells me it's already the newest version.
> apt-get install zlib1g-dev also tells me it's already the newest
> version.  apt-get install libc6 also tells me it's already the newest
> version.

Just download (you might have to do that manually) zlib1g 1:1.1.4-1 and
install it with dpkg.

> I'm completely clueless now because on one hand my versions are
> supposed to be the newest available and on the other hand the libc6
> version seems to be too low..

If your system were running unstable, zlib1g's dependancies would be


Reply to: