[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cdparanoia & cdrom as user



On Fri, 2002-10-11 at 15:14, Hubert Chan wrote:

> You get the same error when you run it as root?  I thought you said it
> worked as root.

Sorry, I misread that, had a hard day.  As root I get 

Checking /dev/cdrom for cdrom...
	Testing /dev/cdrom for cooked ioctl() interface
		/dev/scd0 is not a cooked ioctl CDROM.
	Testing /dev/cdrom for SCSI interface
		generic device: /dev/sg1
		ioctl device: /dev/scd0

Found an accessible SCSI CDROM drive.
Looking at revision of the SG interface in use...
	SG interface version 3.1.24; OK.

CDROM model sensed sensed:  CD-R/RW RW7060S 1.20 


Checking for SCSI emulation...
	Drive is SCSI

Checking for MMC style command set...
	Drive is MMC style
	DMA scatter/gather table entries: 127
	table entry size: 32768 bytes
	maximum theoretical transfer: 1769 sectors
	Setting default read size to 13 sectors (30576 bytes).

> Dale> I realize now the reason I can mount a data cdrom is that fstab
> Dale> has option of user for /dev/cdrom.  When I changed it to defaults
> Dale> I could not mount it. ...
> 
> That is normal.  Only root is allowed to mount filesystems, unless the
> user option is specified in fstab.  See the mount man page.

OK I learned something today.  So all I should need to read audio cd is
permission.  Groups seem OK and they are world readable also.



Reply to: