[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: error upgrading woody to sid (passwd)

"Sebastian Schinzel" <soidberg@web.de> writes:
> Hi!
> I have trouble upgrading from woody to sid:
> The error after #apt-get dist-upgrade is:
> ************************************************************************
> Preparing to replace passwd 20000902-12 (using
> .../passwd_1%3a4.0.3-3_i386.deb) 
> ...
> Unpacking replacement passwd ...
> dpkg: error processing
> /var/cache/apt/archives/passwd_1%3a4.0.3-3_i386.deb (--un
> pack):
>  trying to overwrite `/usr/share/man/de/man1/chsh.1.gz', which is also
> in packag
> e manpages-de
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> ************************************************************************
> Ok. Finally it worked by removing manpages-de, but thats not very
> elegant.
> This bug seems to be reported at:
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=162097&repeatmerged=yes
> Its from 09/23 and for me it sounds that they fixed it.
> Does anyone know a better solution for this?
> Shall I write a new bugreport about this (never done this before)?

I personally just download the offending *.deb file(s) manually and
do, for example:

        dpkg -i --force-overwrite passwd_1%3a4.0.3-3_i386.deb

I just last week did a woody->sarge upgrade and had to do this a
couple of times. Nothing seems broken so far as a result.


Reply to: