[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No X clients start

Michael D. Crawford said:
> I have a brand-new woody r0 installation on a PowerPC macintosh.
> I installed X11 and some clients by selecting mozilla, evolution and a
> few others in dselect and then picking up their dependencies.  I know I
> have gnome-panel, gnome-core and a bunch of gnome stuff.
> But when I run startx, the X server starts up, but no clients do.  I
> don't get the gnome splash screen or the gnome desktop.  I looked at the
> startx script and I would have expected at least an xterm to start up,
> but I don't get even that.
> Is there another package I need to install to get the right Gnome startup
> scripts?

did you put the gnome stuff in your ~/.xinitrc ? perhaps the
windowing system is not fully configured with a default window manager
(I'm not sure how it goes about doing this in the recent builds
of debian, I miss the /etc/X11/window-managers way in i think it was
debian 2.0). First thing I would do is:

echo "exec `which gnome-session`" >~/.xinitrc

assuming gnome-session is the command to use(it's worked for me
in the past, although on SuSE8 I've noticed they have just a plain
'gnome' binary.. I'm not a gnome user so I don't know if there
is a difference or not ..)

another thing you could try is install tasksel and select the
gnome task(s) that may help too

good luck


Reply to: