[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: network unreachable after kernel build

scripsit George Khoury:
> I installed woody with the 2.2.20-idepci kernel last week, and yesterday 
> I built 2.4.18 from source using kernel-package. Now the network is 
> unreachable, even in ping. Honestly I have no idea what is going on. 
> Here's why. When I run dmesg, I get (only including network card items 
> for brevity):
> natsemi.c:v1.07 1/9/2001  Written by Donald Becker <becker@scyld.com>
> http://www.scyld.com/network/natsemi.html
> (unofficial 2.4.x kernel port, version 1.07+LK1.0.14, Nov 27, 2001  
> Jeff Garzik, Tjeerd Mulder)
> eth0: NatSemi DP8381[56] at 0xe0800000, 00:02:e3:16:ff:59, IRQ 5.
> eth0: link up.
> eth0: Setting full-duplex based on negotiated link capability.
> I got the same output with the old kernel, except eth0 had an IP 
> address. One major difference in the kernels is that I built in the 
> network card driver -- does this cause problems?  Any help is greatly 
> appreciated.

I've got a box with the NatSemi chipset, too.  With the stock Woody 2.2
kernel, I get the same result -- if I can get eth0 up, there's no IP
address and no network connection.  Normally, the dh-client just hangs.

Thanasis Kinias
Web Developer, Information Technology
Graduate Student, Department of History
Arizona State University
Tempe, Arizona, U.S.A.

Ash nazg durbatulûk, ash nazg gimbatul,
Ash nazg thrakatulûk agh burzum-ishi krimpatul

Reply to: