[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

network unreachable after kernel build

I installed woody with the 2.2.20-idepci kernel last week, and yesterday I built 2.4.18 from source using kernel-package. Now the network is unreachable, even in ping. Honestly I have no idea what is going on. Here's why. When I run dmesg, I get (only including network card items for brevity):

natsemi.c:v1.07 1/9/2001  Written by Donald Becker <becker@scyld.com>
(unofficial 2.4.x kernel port, version 1.07+LK1.0.14, Nov 27, 2001 Jeff Garzik, Tjeerd Mulder)
eth0: NatSemi DP8381[56] at 0xe0800000, 00:02:e3:16:ff:59, IRQ 5.
eth0: link up.
eth0: Setting full-duplex based on negotiated link capability.

The only difference from the old kernel is the "at" address. It used to be 0xe08f0000. When I run ifconfig, I get:

george@rickety:~$ /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:02:E3:16:FF:59
        RX packets:0 errors:0 dropped:0 overruns:0 frame:0
        TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:100
        RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback
        inet addr:  Mask:
        UP LOOPBACK RUNNING  MTU:16436  Metric:1
        RX packets:58 errors:0 dropped:0 overruns:0 frame:0
        TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:0
        RX bytes:4020 (3.9 KiB)  TX bytes:4020 (3.9 KiB)

I got the same output with the old kernel, except eth0 had an IP address. One major difference in the kernels is that I built in the network card driver -- does this cause problems? Any help is greatly appreciated.

George Khoury
UCSB Physics

Reply to: