[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Enough time wasted, moving on

Hash: SHA1

I've been ignoring this thread for a while, but I thought I'd add some support 
for Harry's point of view here.

Firstly, stable vs woody.  We recently had a thread on -devel where we 
concluded that ordinary users are best running testing.  You can't complain 
they have a hard time installing testing when that is what we tell them to 
run.  Yes the installation CDs may be fscked, but it sounds like the problems 
Harry had were to do with installation in general and the CDs didn't get in 
the way to me.

I'll now post the story of what happened last time I installed debian.  The 
situation isn't that dissimilar from Harry's.
- --
I've been using unix for a long time and debian for a while.  Recently I 
upgraded my machine again and I've had a number of problems.  Furthermore, if 
I'm having problems, just how bad is Debian for new users? We all hear 
stories about how people were shown linux years ago and found it _way_ too 
difficuilt; based on my experiences I think it is still happening.

Ok, the first step in my upgrade process was upgrading everything except the 
hard drive.  Before turning the old machine off I recompiled the kernel with 
support for practically everything, a buggy bios, etc. The point I'm trying 
to make is that I went out of my way to minimise problems.

After plugging everything in I was relieved to see lilo come up and things 
seemed to be booting fairly well.  Suddenly a kernel panic came on screen, 
whoops :-(.  I rebooted and picked one of my older kernels from lilo ... X 
fails to start but I get a login prompt.  For those interested, after a bit 
of experimentation with recompiling the kernel I've found the K7 option seems 
to cause problems.

My next problem was getting X and the modem working.  I've got an ISA modem 
which I've been using on IRQ 4 at 3F8, I found it worked more reliably than a 
PCI winmodem. pon resulted in the required beeping noises, much to my relief, 
but /var/log/messages informed me my serial line wasn't clear with bit 7 set 
to zero. Repeated attempts failed at different stages, once even managing to 
connect.  wvdial claimed not to be able to find the modem at all.  Do you 
realise just how hard it is to do _anything_ in debian without access to the 
net? I wasn't able to get documentation or install useful looking packages.  
After a while I guessed an IRQ conflict with the bios, disabled the built in 
serial ports and the net came up.  Good old ISA...

Next was X.  Something with the framebuffer was working since I had a penguin 
coming up on startup.  According to the motherboard's manual I had a via 
chipset which is uses some trident blade chip.  However X autodetect refused 
to find my mouse (PS2)... Eventually I worked out that for some reason 
.devfsd had dissapeared so devfsd wasn't loaded, and so my mouse device 
didn't exist.

Unfortunatly, booting X resulted in lockups and similar.  I had carefully set 
things like 640x480 resolution with a low referesh rate to avoid this.  It 
turned out to be a bug in the video card's driver and required manually 
disabling X extensions in the XF86-Config file.  

Sound required a number of attempts at recompiling the kernel and I still 
don't have ALSA or arts working.
- --
Anyway, my point is that installing Debian is a nightmare compared to anything 
else. Compare the leaps and bounds that system ease-of-use has gone through 
over the past two years, and then look at the installation process.  I know 
there are projects working on this, but they aren't here yet, so I think 
Harry's point is fair.


PS: Not that installing XP is any better.  The one time I did that I had to 
rip every single piece of hardware out of the machine to get it to install, 
and then add them back one by one.  Without ripping anything out, the 
installer either hangs or leaves the system unbootable.

Version: GnuPG v1.0.6d-cvs (GNU/Linux)


Reply to: