[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ALSA modules not loading

Yet another ALSA question ...

Problems are with a maestro-2 (es1968) soundcard
running on 2.4.18-ac3, ALSA compiled from source on an
up-to-date Woody system.[Same problems occurred with
other kernels, but I never fixed them.]

In a nutshell, the ALSA modules won't load
automatically.  If I use "insmod" I can insert the
relevant sound modules one-by-one and ALSA works. If I
use "modprobe" I can get all of the sound modules to
load _except_ for "snd-card-es1968". I get the
following error:

lib/modules/2.4.18-ac3/alsa/snd-card-es1968.o: invalid
parameter parm_snd_dac_frame_size

/lib/modules/2.4.18-ac3/alsa/snd-card-es1968.o: insmod

/lib/modules/2.4.18-ac3/alsa/snd-card-es1968.o failed

/lib/modules/2.4.18-ac3/alsa/snd-card-es1968.o: insmod
snd-card-es1968 failed

I think this error is probably whats stopping the
modules from loading automatically when I start a
player, like alsaplayer. I've checked in
/etc/modules.conf and everything looks fine. The
parameter mentioned as being invalid is fine per the
ALSA docs. I also tried it with a few different values
and still no dice.

Any ideas? Why would insmod work but not modprobe?



Do You Yahoo!?
Try FREE Yahoo! Mail - the world's greatest free email!

Reply to: