[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sound Woes

I have an almost new Debian installation (Woody) that is giving me a
great deal of grief getting sound configured.

I actually have two soundcards in my machine to chose from.  I have a
Creative CT4750 PCI sound card that had worked in this hardware
configuration under Red Hat.  I also have the on-board sound from my ECS
k7s5a motherboard that is supposed to support the  ac97 codec.

When I did the install I did not have the Creative card in and Debian
failed to negotiate the on-board sound.  I then disabled the on-board
sound in the bios and installed the Creative Card.

I tried to modprobe sb.o to et the module for this card to work (i'm
assuming that that was the right module) but that failed with the

ray:~# modprobe sb
Note: /etc/modules.conf is more recent than
/lib/modules/2.2.20-udma100-ext3/misc/sb.o: init_module: Device or
resource busyHint: insmod errors can be caused by incorrect module
parameters, including invalid IO or IRQ parameters
/lib/modules/2.2.20-udma100-ext3/misc/sb.o: insmod
/lib/modules/2.2.20-udma100-ext3/misc/sb.o failed
/lib/modules/2.2.20-udma100-ext3/misc/sb.o: insmod sb failed

I did the same thing with the ac97_codec.o (again, assuming that is the
right module for my on-board sound) and that seemed to work.  However,
after I re-enabled the onboard sound in my bios,  my pc hung up halfway
through booting linux.

On a brevious installation of Red Hat with the exact same hardware, I
was able to get the sound configured with Sndconfig.  I even went out
and got the sndconfig package from Debian, but it wouldn't recognize my



Ray Raddatz

Reply to: