[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: CD Burner Permissions



Thus spake Nathan E Norman:
> On Mon, Sep 24, 2001 at 10:02:00AM -0600, Adam McDaniel wrote:
> > On Mon, Sep 24, 2001 at 09:28:57AM -0400, Stephen Gran wrote:
> > > From /etc/fstab:
> > > /dev/scd0 /cdr iso9660 ro,defaults,users,noauto 0 0
> > > 
> > > ls -l /dev/scd0
> > > brwxrwxrwx    1 root     cdrom     11,   0 Feb 11  2001 /dev/scd0
> > > 
> > > So - adduser jane cdrom
> > > 
> > > Completes normally, but still no permission to write to drive.  I seem
> > > to remember that there are different /dev/ entries, one for reading and
> 
> This question's been asked and answered several times in the last few
> weeks ... check the archives at lists.debian.org.  You need scsi
> generic support in your kernel to do cd writing.  Use the sg? devices
> to access the drive.  cdrecord -scanbus can help you figure out what's
> going on.
> 
> Your /dev/scd0 permissions are fubar ... should be 
> 
>   brw-rw----    1 root     cdrom     11,   0 Feb 11  2001 /dev/scd0
> 
> Allowing permissions to "all" makes the cdrom group superfluous.
Hello all,
OK - so far I've looked into some of the things people have mentioned,
which I'll try to detail in some coherent shape:

chmod the permissions on /dev/scd0 back to how they should have been (I
changed them that way to see if I was miising something with groups -
quite obviously, didn't work).  Thanks for pointing it out to me, as I
forgot to change them back.

ls -l /dev/sg0:
crw-rw----    1 root     cdrom     21,   0 Jan 29  2001 /dev/sg0

cdrecord -scanbus:
Cdrecord 1.9 (i686-pc-linux-gnu) Copyright (C) 1995-2000 Jörg Schilling
Linux sg driver version: 3.1.19
Using libscg version 'schily-0.1'
scsibus0:
         0,0,0     0) *
	 0,1,0     1) *
	 0,2,0     2) *
	 0,3,0     3) 'YAMAHA  ' 'CRW8424S	 '1.0d' Removable CD-ROM
	 0,4,0     4) *
	 0,5,0     5) *
	 0,6,0     6) *
	 0,7,0	   7) *

Which is all as it should be, on the face of it.  The fact that the
burner is the only thing on the SCSI bus means that it should be
/dev/sg0, no?  Or perhaps I'm still not getting it - I'm kind of tired
and not thinking perhaps as straight as I should.  If anyone can clear
this up for me, I'd appreciate it.

Did some list searching, but the only advice I found was directed
towards people using SCSI emulation, rather than straightforward SCSI,
and they didn't seem to be having this problem, or not quite.

Thanks again, everyone,
Steve
-- 
	Something mysterious is formed, born in the silent void.  Waiting
alone and unmoving, it is at once still and yet in constant motion.  It is
the source of all programs.  I do not know its name, so I will call it the
Tao of Programming.
	If the Tao is great, then the operating system is great.  If the
operating system is great, then the compiler is great.  If the compiler is
greater, then the applications is great.  The user is pleased and there is
harmony in the world.
	The Tao of Programming flows far away and returns on the wind of
morning.
		-- Geoffrey James, "The Tao of Programming"

Attachment: pgprhj5os24rU.pgp
Description: PGP signature


Reply to: