[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: woody: segfaulting all over the place

* Frank Preut (debian@blinx.de) spake thusly:
> i didn't think of memory because i didn't change anything there in the
> last six months.. but maybe it got wrecked recently so i tested it with
> the latest version 2.7 of memtest.. and indeed it came up with an error
> at the address 04e0 during test no. 4 so i tried playing around with the
> two 64 mb modules and the exact same error occurs no matter which module
> is installed in which lot.. ?? wtf, what is wrong here? and why did it
> work before, i'm quite sure that i got an error when i tested memory
> before.. could it be the cache (32k of level 1, 512 of level 2)? and
> couldn't do anything about that, right?

Memory words may be stripped accross both modules. If so, swapping the
modules will put the error in a different part of the same word, and the
address will not change. Maybe.

E-mail dmaziuk at bmrb dot wisc dot edu (@work) or at crosswinds dot net (@home)
http://www.bmrb.wisc.edu/descript/gpgkey.dmaziuk.ascii -- GnuPG 1.0.4 public key
The wombat is a mixture of chalk and clay used for respiration.       -- MegaHal

Reply to: