[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: modem diagnostic?


Still can't seem to dial out ...

>  In any
> case, undo whatever -Running Linux- told you to do (simplest way is to
> purge and reinstall ppp).  Then run pppconfig as root, follow instructions,
> and try to connect with pon.  If you have trouble, run plog and post the
> output.

Here's the meat: I did this. Tried every permutation of PAP, CHAP and
CHAT, dialup # with and without area code, and never got beyond this
output from plog:

"pppd 2.3.11 started by root, uid0
connect script failed

... am going to contact the ISP today to see if there's any information
they can provide. "Connect script failed" to -me- says that the modem is
dialing but that the connection is crapping out because there's something
wrong with the configuration.

However, just to make the picture weirder, I tried wvdial. The wvdialconf
program gave me -this- message:

"Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- ATQ0 V1 E1 -- ATQ0 V1 E1 -- nothing.

Port Scan<*1>: S1 S2 S3

Sorry, no modem was detected! Is it in use by another program? Did you
configure it properly with setserial?"

... so I began to explore setserial! Here is what setserial gives for

"/dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4"

... wufff. Is there anything wrong here? One program can't detect my
modem, but it looks (to my newbie eyes) like the modem is A-OK.



"Everyone's Portal to Nothing At All"

Reply to: