[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Broken e2fs...please hellp

Hello all,
   It appears that the superblock is bad?  I have tried some other superblocks
with no luck.   The following commands below show the problem.  I can't mount
the file system either.  I checked the partition table with fdisk and everything
looks fine...except the partition no longer lists the file system as a "linux
ext2" description, but a "linux" description.

Any ideas?  I must to get info. off this file system.

I'v also tried 8139 and others.
grumpy:~# e2fsck -b 16386 /dev/sdc1

e2fsck 1.18, 11-Nov-1999 for EXT2 FS 0.5b, 95/08/09
e2fsck: Bad magic number in super-block while trying to open /dev/sdc1

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

grumpy:~# dumpe2fs /dev/sdc1

dumpe2fs 1.18, 11-Nov-1999 for EXT2 FS 0.5b, 95/08/09
Filesystem volume name:   <none>
Last mounted on:          <not available>
Filesystem UUID:          e8c5ce19-c7f3-4b42-9279-38b09bc55064
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      filetype sparse_super
Filesystem state:         not clean with errors
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              26886144
Block count:              53763522
Reserved block count:     2688176
Free blocks:              31794011
Free inodes:              26598162
First block:              0
Block size:               4096
Fragment size:            4096
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         16384
Inode blocks per group:   512
Last mount time:          Wed May  2 15:18:07 2001
Last write time:          Thu May  3 09:56:58 2001
Mount count:              1
Maximum mount count:      20
Last checked:             Wed May  2 15:06:10 2001
Check interval:           15552000 (6 months)
Next check after:         Mon Oct 29 14:06:10 2001
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:               128
ext2fs_read_bb_inode: Attempt to read block from filesystem resulted in short

droman@chattycow.com   or   droman@ti.com

fn:Dean Roman

Reply to: