[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem with dpkg-buildpackage

Jason Healy <jhealy@logn.net> wrote:
>At 988753708s since epoch (05/01/01 10:48:28 -0400 UTC), Jeremy Rosen wrote:
>> Usually, I just type dpkg-buildpackage in the proper directory, and
>> everything is built correctly. But since a couple of days, dpkg gives me
>> the following error
>>   "invalid sign interface specified"
>> I use the testing, qith a 2.4.3 kernel. I havn't studied (yet) how
>> dpkg works, I usually use apt, but to build this software I just did
>> what the readme told me.

(dpkg-buildpackage isn't one of the parts of the system where you could
use apt instead, incidentally.)

>I hit this yesterday when I was trying to build the nVidia drivers.  I found
>that by adding a '-pgpg', it shut up and did its work correctly.

Yes, that's a workaround for dpkg-dev 1.9.0; it's fixed in 1.9.1,
according to the changelog.

Colin Watson                                     [cjw44@flatline.org.uk]

Reply to: