[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg can't find ldconfig?

Thanks to everyone for the responses! I think I know what caused the
problem, but fixing it is still a mystery.  

I tried installing mcrypt at one point, which required libc6 2.2.1-2 or
greater (a newer version than the one in potato).  Later on, when I
tried to install something via gnome-apt, it wanted to put the libc6
that came with potato back.  Innocently, I believed it'd just replace
everything the way it was ... I think ldso got dumped in that process. 
I have since reinstalled Ximian Gnome, so I figured that apt was
working okay (Ximian's install uses apt), but now it doesn't seem to be
okay at all.

Any suggestions on how I should proceed?  Should I reformat and start
over or try to install ldso manually? Should I try to upgrade to Woody
(can I even do this without ldconfig/ldso?)?  Or maybe there's a better


--- Mathias <Mathias_Bind@gmx.de> wrote:
> >     Reading Package Lists... Done
> >     Building Dependency Tree... Done
> >     Note, selecting ldso instead of ldconfig
> >     Sorry, ldso is already the newest version
> >     0 packages upgraded, 0 newly installed, 0 to remove and 4 not
> > upgraded.
> Hmm, this looks like a dependence problem. You should make shure
> the
> packages you like to install are build for your system
> (potato/woody). There
> are some differents like glibc-2.1.3 in potato and glibc-2.2 in
> that
> makes ist impossible to merge these packages, except you like to
> compile
> those packages for your system.
> Mathias

Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 

Reply to: