[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

LILO+IDE+SCSI Problems



Hi,
  I just installed debian for the first time and have run into a problem
getting LILO to boot properly.  I think it is the standard 'LI' problem
with SCSI and IDE disks, but I have tried several things I found on the
web, none of which have been successful.

  My set up is one primary master IDE hard drive with WinNT on a FAT16
partition and the NT boot loader in the MBR.  Then I have a IDE CD-ROM in
the secondary master and two SCSI hard drives, IDs 0 and 1.  The first
SCSI hard drive has LILO on the MBR, a 20G /boot partition and the
remainder (4GB) is /.

  My lilo.conf has boot=/dev/sda and root=/dev/sda2.  I have tried
disk=/dev/sda, bios=0x80 through 0x82 with no success.  Yes, I
(eventually) remembered to rerun lilo after each change, but have not seen
any change.  I also tried booting with a disabled BIOS detection of all
IDE channels, with and without the above disk & bios settings.

  Can someone give me a clue?  Is there a way to determine which bios
setting I should be using?  Do I need to include the bios settings of the
other drives?

  Thanks in advance.



Anm



Reply to: