[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trouble compiling kernel -- solved

On Sat, Nov 25, 2000 at 10:48:16PM -0500, Thomas J. Hamman wrote:
> Thanks to a swift response, my problem was solved--apparently I just
> needed to symlink /usr/include/asm to /usr/src/linux/include/asm-i386

no you don't, and should NOT symlink /usr/include/anything to
/usr/src/linux/anything that is plain wrong.

the problem is the latest libc6-dev package is broken and missing the
header files which are installed in /usr/include/asm and such.  this
will be fixed shortly, or probably already is.  

> Though I wonder what made me suddenly need the symlink, if I didn't have

you don't, and should not have one.  put it back the way it was, and
upgrade libc6-dev.  

> it before, or what made me lose it if I did have it before.  (I notice I
> did already have an asm-i386 symlink pointing to the right place, just
> not an asm link.)

these header files are provided by libc under debian, as they should

Ethan Benson

Attachment: pgpFwZy96RsWl.pgp
Description: PGP signature

Reply to: