[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gpm and X and mouse (fwd)

	Subject: Re: gpm and X and mouse (fwd)
	Date: Tue, Sep 19, 2000 at 08:49:55AM -0500

In reply to:W. Paul Mills

Quoting W. Paul Mills(Paul@Mills-USA.com):
> I have had 3 or 4 computers, and many different pointing devices.
> All have worked fine this way. Mostly Logitech mice, but others
> also.
> Chris Majewski <majewski@cs.ubc.ca> wrote:
> : It's been three computers and four mice already, and I've never 
> : had this working, so I'm curious if anyone has got it to work and 
> : under what circumstances, so that maybe the next time I spend money 
> : I can make duplication of these circumstances a consideration.
> : -chris
> : ---------- Original Message ----------------------------------
> : From: Krzys Majewski <majewski@cs.ubc.ca>
> : Date: Mon, 18 Sep 2000 13:19:51 -0700 (PDT)
> :>I've tried to tell X to use the fifo /dev/gpmdata as its
> :>pointing device but it doesn't work. The mouse behaves fine
> :>under gpm (even cut&paste works) but is unuseable under X. The
> :>mouse cursor does move when I move the mouse, but in
> :>completely erratic and unpredictable ways. The only way I've
> :>got the mouse to work under X is to not use the gpm fifo, and
> :>to stop gpm before starting X. My mouse is a Logitech 3-button
> :>PS/2 type. -chris

Interesting.  I have 2 potato systems, #1 is a Slink upgraded to
Potato box.  On this box I have /dev/mouse linked to /dev/ttyS1
and have in /etc/gpm.conf 'device=/dev/ttyS1'.  Mouse works fine
in X and console.  This box does not have a /dev/gpmdata entry.

On box #2 I had problems with the upgrade so I did a new install of
potato from cd's.  I use the same /etc/gpm.conf as box 1.  I tried
linking ./dev/mouse to /dev/ttyS1 and the Mouse didn't work in X.
I then linked /dev/mouse to /dev/gpmdata.  Mouse works in X and
console now.  

This and other problems lead me to think that a new install sets the
system up differently the an upgrade does.  ie  box #1 does not have
any /dev/ttya or /dev/ptya devices but box #2 does. The latest version
of Splitvt works on box 2, using /dev/ttya* devices but gives an error
of 'no available pseudo terminals' and an strace shows a failure on
/dev/ptya not being there.  I didn't see these problems in going from
2.0 to 2.1.

:-) HTH, YMMV, HAND :-)

Build a system that even a fool can use, and only a fool will use it.

Reply to: