[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

net-help needed : adsl + dyn-IP (? + dhcp ?) . (re-)starting from scratch



hello.

-- -- -- --

an excerpt from the text, below, which may be the root of the issue:


2) crucial question:

   do i need to have dhcpcd up-and-running before or after i start-up the pppoe
client-daemon ?  and why do i need to have dhcpcd running, at all? ( shouldn't
the pppoe software be handling this? )


-- -- -- --




and, if you might have the time, i would appreciate some comments and
suggestions regarding the following.  i have a number of unanswered questions
about the net-setup here. ( and will continue to make sure they are answered,
eventually. i.e.: by posting them more clearly. maybe now will be the "when",
for some of them. )


i've marked each section of this email, as per the topics which i am having some
problems with.



-- -- -- --

the current situation, and the previous work:



i've tried to get an installation of debian (potato) working with an adsl
connection, and have been failing completely.

i'd like to start from square zero, to see what learning that i might miss-out
on if i was otherwise able to use a "plug and play" solution.  

( "instant gratification", and no lessons-learned ... the ms-w method?)



i've looked through howtos (ethernet, pppoe? , * ), and other documents, to no
avail.  maybe i'm missing something.


i've tried, in various combinations: the deb package of pppoe ; dhcpcd ; pump .
none of these combinations have worked.


i tried something like "pppoe -d" with whatever argument is used to send the
debug output to a file, and got a command-line full of odd-looking characters,
and a file full of hexadecimal values that i have no idea about the meaning of. 
this file 


i chose the IPv6 module, when installing debian, because it seemed like a neat
thing (value-added for my impression of the installed OS).  i'm wondering if
this might be the cause of any problems.



i cannot currently contact the DSL provider for assistance, as my account is
severely delinquent, and one note to them about this could spoil the connection.
furthermore, i'm very unsure about their ability to be a help with this.  ( the
microsoft marketing-program, while far from stamping-out the usage of Linux [
and foolish of them, if they thought that otherwise might happen ]  has left a
blank-spot where "linux" should be, in the collective public knowledge-set .  i
find it to be a personal goal to remedy this, to provide a better system if, we
can.  we darn well should be able to, with the wealth of (free!) available
tools. )


-- -- -- --

'route-add's, and the general dynamic-ip-assigning process:



i've looked through the log-file of the connection-client (?) that was provided
by Pacific Bell, for connecting to the DSL service from ms-windows.  

i'd found two "route add" commands, each with the same gateway and netmask, but
each with a different metric.  for some reason, the log-file, today, is only
showing one "route add", with metric 2.


i'm wanting to know how this is (?supposed to be?) handled with the tools on
debian:


excerpts from the (ms-w dsl-connection client) log-file:

" Connect: Tap IPAddress: 169.254.131.55  "
...
" Dest:fea9 mask:ffff Gate:3783fea9 If:3000004 Metric:2 "
...
" route add 169.254.0.0 MASK 255.255.0.0  169.254.131.55 METRIC 2 "
...
" Setting IP Address through DHCP"




( in the older log-file, there was a line after that which read something like: 
" route add 169.254.0.0 MASK 255.255.0.0  $ipAddress METRIC 1 "  

where $ipAddress = 169.254.0.130 , which is different than what's in the
log-file today.



...and how can the address have a zero in it, like that?


... and looking at the log-file again, the METRIC 1 is used /on _disconnect_/.
why is it not just a simple "goodbye" that can be offered to the server? 

  (e.g.: why another "route add", and why the different metric? )


<excerpt>

07/02/2000 23:20:06 - Disconnect: Tap IpAddress: 169.254.0.130
07/02/2000 23:20:06 - Route supports METRIC command.
07/02/2000 23:20:06 - Dest:fea9 Mask:ffff Gate:8200fea9 If:3000004 Metric:1
07/02/2000 23:20:06 - AddChangeRouteApi - Error [87] from Add Route
07/02/2000 23:20:06 - route add 169.254.0.0 MASK 255.255.0.0 169.254.0.130
METRIC 1
07/02/2000 23:20:06 - ExitCode [0] from Route Add

</excerpt>

 )






-- -- -- --

access-concentrators:



i have some sort of an address, which i hope is an access-connector, though (as
far as I know, which isn't very far on this) it may be something simply pointing
to the "router" (what i want to call the DSL-modem) that they also provided ( ==
the thing that has the dsl-line from the phone-line splitter connected to it, as
well as the ethernet cable )

: 13041039917991-rback1.frsn01


it's what is at the end of the ms-w client log-file:

"s-champ successfully connected to 13041039917991-rback1.frsn01


-- -- -- --

netmasks:


my confusion is compounded by the fact that i have two different subnet-masks,
and am not sure which should be used, though i've used the one for the
ethernet-card, with debian.


	"Kingston EtheRx PCI ...":	255.255.0.0
	"NTS PPPoE adapter":  		255.255.255.0


( both of these were obtained from a window on the ms-w dsl-connection client)

-- -- -- --


finally:

- - -

1) hex-values (?on packet-contents?):

    from looking at some PPPoE info, and looking at the output of "pppoe -d *",
it's looking like i've been able to establish a connection.  though i have no
idea what the hex values are supposed to mean, after the first line of each
packet-report, it looks like the pppoe client has gone through the steps of
discovery-mode ( PADI -> PADO -> PADR -> PADS ), and into session-mode.  and yet
I try "lynx http://www.aj.com"; and get something like "unable to connect to
remote host"

- - -


2) crucial question: timing :

   do i need to have dhcpcd up-and-running before or after i start-up the pppoe
client-daemon ?  and why do i need to have dhcpcd running, at all? ( shouldn't
the pppoe software be handling this? )


- - -


i can send the copies of the mentioned log-files, if it will be a help.



i'd like to install the network support, and to know _how it's working_, (have
actually been wanting to gain some sysadmin skills, looking greatly forward to
it) but might be happy with the former sans the latter, for now.  


i would appreciate any help, sincerely.

(and perhaps i should be asking on the "mentors" list for this, as i have
already proposed some assistance on the FreeSWAN deb-package, but I did not want
to pester anyone on that list, with this, without getting a go-ahead on it. )



after it is working (if! and when.) i look forward to participating (as-hoped:
extensively) on the debian project.  it's a great-looking alternative to ms-w
that we've got going, here. (and the 'ham' background seems to lend the debian
project towards telecom, an important facet in an OS of the age. )




and thank you.




-- sean champ



Reply to: