[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Desperately looking for help with a PCMCIA SCSI card!

maybe the ioport is really already in use
try "less /proc/ioports""

On Tue, Jul 04, 2000 at 02:07:31PM +0200, Juan C. Amengual wrote:
> Dear sirs,
> first of all, beg your pardon for the dramatical subject of this e-mail
> ;-), but I'm really desperated. My problem:
> I have an ASUS F7400 Laptop (a.k.a. ASUS Grandio Laptop). I have
> installed Debian 2.2 (a.k.a. Potato). I have a PCMCIA SCSI Card: Adaptec
> SlimSCSI 1480A Cardbus (Adaptec APA-1480 SCSI Host Adapter). I am still
> trying to make it work under Potato. When I insert the card in any
> socket, I always receive the following message:
> aic7xxx: <Adaptec PCMCIA SCSI controller> at PCI 35/0/0
> aic7xxx: I/O ports already in use, ignoring.
> scsi : 0 hosts.
> I can't imagine why the I/O ports are already in use. Well, let's tell
> the whole story.
> I install kernel-source-2.2.15 package and also the PCMCIA source. I
> compiled both the kernel and modules with make-kpkg (kernel-package).
> After installing the .deb packages, I tried to make the PCMCIA card work
> and I got the messages above. Yes, both cb_enabler and apa1480_cb are
> charged in memory (lsmod). I have repeated this process as much as five
> times (of course, selecting SCSI support in kernel, but choosing no SCSI
> low-level adapter). Desperated, I have purged all 2.2.15 stuff (source,
> image, modules, etc.) and I have installed (today) the 2.2.17
> kernel-image (potato) and the corresponding PCMCIA modules. Okay, let's
> give us a chance! ;-(( No, the same error messages. I have read the
> whole PCMCIA HOWTO, checking if the config.opts defines a large enough
> IO memory range and ... ¡yes! Everything seems to be okay, but my card
> is still not working! A colleague of mine has the same laptop. He
> installed Mandrake and ... the same card is perfectly working in his
> system. I have checked the config files in the Mandrake and it seems the
> same as in my Debian system. Where the error is? Must I have to install
> Mandrake? ... No, ¡never! ;-)
> Please, anybody can help me? I have already posted this message in the
> spanish users list (a week ago) and I got no answer to my problem. I
> have just suscribed to this list as the last chance to make the card
> work. And ... some more info: the card works fine in the Windoze also
> installed in my lapton. It reports:
> IRQ=11; Memory=06020000-06020FFF; I/O port=1000-10FF;
> Memory=06010000-0601FFFF
> Of course I have checked all of this in /proc/interrupts and
> /proc/ioports. Concretely the I/O port range is not in use. Thank you
> very much in advance for your help and patience.
> Best regards,
> P.S.: By the way, someone can tell me how to use the kernel-package
> (make-kpkg) to configure the PCMCIA modules? I have tried make-kpkg
> modules_config and it didn't work. Well, I am trying to build the
> "trusted" versions for cardctl, etc. and there is no way of achieving
> this with make-kpkg. Have I to return to the "old-style" stuff (you
> know, make dep; make clean; make bzlilo, etc.)?
> ================================================================================
> JUAN CARLOS AMENGUAL                    Treasure the moments
> UNIVERSIDAD JAUME I                     touched with joy,
> DEPARTAMENTO DE INFORMÁTICA             but remember the moments
> CAMPUS DE RIU SEC, EDIFICIO TI          tarnished and stained.
> Phone: +34 964 728361                   Wayne Hussey (The Mission)
> Fax: +34 964 728435                     - "Wake", The First Chapter, 1986/87,
> e-mail: jcamen@inf.uji.es                               Phonogram -
> ================================================================================
> -- 
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Thomas Guettler <guettli@interface-business.de>

Reply to: