[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: rank newbie - no mouse

Bill Barnes wrote:
> >===== Original Message From fbochicchio@galactica.it =====
> >On Fri, 30 Jun 2000 06:34:50 sido wrote:
> >>
> >>
> >> I installed Debian Linux and everything works great except for X which
> >> looks fine except the mouse doesn't move.  I've re-installed the OS 3
> >> times now and searched for help on the mouse but not come up with much.  I
> >> tried to run mouseconfig but couldn't find it.
> >>
> >> The mouse is a 3-button mouse, manufacturer Digital.
> >>
> >> ls -l  /dev/mouse
> >>
> >> /dev/mouse   -> ttyS0
> >>
> >> That doesn't seem right to me but I can't figure out how to change it
> >> either.
> >
> >If the mouse is a serial mouse attached to the first serial port ttyS0 is
> >correct.
> Try to find 'gpm-config'.
> If you installed KDE it is at debian applications > apps > system > admin.
> You can bring up the main KDE menu with Alt-F1 and cursor/return to the next
> level menus.
> In every distro I've tried (Mandrake,SuSE,OpenBSD,etc) the installation has an
> early screen that configures the mouse.  Without exception, any attemp to
> reset the mouse in XF86Setup kills it.
> Good luck,
> Bill Barnes

Switch to a virtual console (Ctrl-Alt-F1, etc) and move the mouse and
see if a square mouse pointer moves around on the screen. If so, that
means that you have gpm running and it knows about your mouse. Look in
/etc/gpm.conf for the details that you need to put into

If you don't have a working mouse in a text console, try running
gpmconfig; it has a test mode that can attempt to autodetect your mouse.

If neither of these works, my suspicion is that your mouse doesn't work
with Linux, for whatever reason.

Is it a serial mouse, or a bus mouse, or a PS/2 mouse, or some sort of
other oddball mouse?

If serial, are your serial ports working properly (CMOS, setserial)?

If bus or PS/2, then the /dev/mouse link is wrong, and should be
pointing to /dev/psaux for PX/2 (I'm not sure what you'd need for a bus
mouse). You can "rm /dev/mouse", then "ln -s /dev/psaux /dev/mouse" to
create a new link.

Reply to: