[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: END Key in Emacs (only in Xterm)


On Tue, Apr 04, 2000 at 02:56:36PM +0200, Michel LESPINASSE wrote:
> On Tue, 4 Apr 2000, Rodrigo Castro wrote:
> > 	I couldn't make my Emacs work yet. Anyway, the problem is with
> > Emacs (in Xterm) and not with XEmacs. I don't know but do you have any
> > other idea? (I already contacted the Emacs maintainer but I didn't get
> > any answer so far).
> I hacked this yesterday in the evening so I can as well post my config
> here. I also contacted the xemacs maintainer about this but no answer
> either.
> I fixed the home/end problem by adding this in my .emacs file :
> ;; better xterm support
> (defun xterm-setup-hook ()
>   (define-key function-key-map "\e[1~" [home])
>   (define-key function-key-map "\e[4~" [end]))
> (setq term-setup-hook 'xterm-setup-hook)

        It worked! I looked at
"/usr/share/emacs/20.5/lisp/term/xterm.elc"and noticed that \e[4~
goes to [select] key. Is it a normal behaviour to beep when it gets
this key? Branden, is that a problem with some configuration of mine
in X or is it only a matter of Emacs? I know I solved this problem but 
I'd like to understand what's going on and why it was working before
some packages updates!! ;-)

        Michel, thank you for your help! :-)

Rodrigo Castro   <rcastro@linux.ime.usp.br>
Computer Science undergraduate student - University of Sao Paulo

Reply to: