[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: END Key in Emacs (only in Xterm)

On Tue, 4 Apr 2000, Rodrigo Castro wrote:

>         It worked! I looked at
> "/usr/share/emacs/20.5/lisp/term/xterm.elc"and noticed that \e[4~
> goes to [select] key. Is it a normal behaviour to beep when it gets
> this key? Branden, is that a problem with some configuration of mine
> in X or is it only a matter of Emacs? I know I solved this problem but 
> I'd like to understand what's going on and why it was working before
> some packages updates!! ;-)

I dont know what your previous config was, but (supposing you did not
upgrade your emacs package) one possible explanation would be that your
xterm still generated the ^[[H and ^[[F sequences for home and end. This
is now considered bogus by the debian as well as upstream X maintainers so
this has changed, but I know debian used the old mappings at some point. I
dont know when the switch occured exactly.

As for the beep problem, I was getting exactly the same thing with
xemacs21. I *think* it is because the xterm.elc uses the [select] key,
while other parts of [x]emacs dont know about select. I would not bet too
much on my explanation though :)

Michel "Walken" LESPINASSE - Development Engineer at Wind River Systems
"We've all heard that a million monkeys banging on a million typewriters
 will eventually reproduce the entire works of Shakespeare.
 Now, thanks to the Internet, we know this is not true."

Reply to: