[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unusual Lilo "LI" problem

On Sun, 02 Apr 2000 17:03:04 Oswald Buddenhagen wrote:
> On Sun, 2 Apr 2000, Marc Moody wrote:
> > I've recently install a new potato system that's been working well for a 
> > couple of weeks.  Yesterday I compiled a custom kernel
> > (2.2.14) (installed using make-kpkg), and now I can't boot my Linux
> > drive.  I CAN boot using the rescue floppy, and everything works
> > fine.  Normally the "LI" problem was easily fixed by rerunning lilo, but
> > that doesn't seem to be working.  This type of setup worked for a year
> > and a half on my old system.  If anyone has any suggestions, I'd be
> > grateful.
> > 
> > I've been dual booting Win95 and potato on a SCSI disc with BootMagic.
> >  /dev/sda1 is my windows partition, /dev/sda2 is my Linux partition.  I
> > do have a tiny partition for the boot manager.  I've tried uninstalling
> > lilo with lilo -u  and using it with and without the linear option in my
> > conf.  I have an older IDE drive on /dev/hda1, but I don't see how that
> > would cause a problem.
> > 
> the boot manager is probably your problem. i know a situation with the
> nt-bootmanager: it does not use the real boot sector to boot a partition,
> but a copy stored in a file. thus, if you recompile your kernel and
> re-run lilo, lilo will update the real boot sector, but the boot manager
> will not realize it and will still run the old code stored in the
> image-file. the old code of course has an invalid (old) map ...
> the solution (for nt - i don't know bootmagic):
> dd if=/dev/sda2 of=/c/bootsek.lin count=1
> where /c is the mount-point of a fat-partition, where the nt-bootloader
> resides. bootsek.lin is an arbitrary name choosen for the image file (you
> would have to use the one, that already exists).
> i hope, that this technique is also true for bootmagic.
> good luck!

Thanks for the help.  I don't think this would work with BootMagic since 
I can't seem to find any image files, just one config file for all of 
the entires.  I tried some trial and error, but it didn't work.  It did 
lead to a solution however.  The problem seems to be my IDE drive on 
hda1.  I re-ran lilo after disconnecting the drive and everything works. 
 When I installed potato, it wasn't installed yet, so that's probably 
why my original setup was ok.  This brings up a new question.  LILO 
keeps setting hda1 as the first drive.  Is there a way to get it to 
think of my SCSI disc as the first drive and still have the IDE 
connected?  Thanks for all your help.


Reply to: