[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unusual Lilo "LI" problem

On Sun, 2 Apr 2000, Marc Moody wrote:

> I've recently install a new potato system that's been working well for a 
> couple of weeks.  Yesterday I compiled a custom kernel
> (2.2.14) (installed using make-kpkg), and now I can't boot my Linux
> drive.  I CAN boot using the rescue floppy, and everything works
> fine.  Normally the "LI" problem was easily fixed by rerunning lilo, but
> that doesn't seem to be working.  This type of setup worked for a year
> and a half on my old system.  If anyone has any suggestions, I'd be
> grateful.
> I've been dual booting Win95 and potato on a SCSI disc with BootMagic.
>  /dev/sda1 is my windows partition, /dev/sda2 is my Linux partition.  I
> do have a tiny partition for the boot manager.  I've tried uninstalling
> lilo with lilo -u  and using it with and without the linear option in my
> conf.  I have an older IDE drive on /dev/hda1, but I don't see how that
> would cause a problem.
the boot manager is probably your problem. i know a situation with the
nt-bootmanager: it does not use the real boot sector to boot a partition,
but a copy stored in a file. thus, if you recompile your kernel and
re-run lilo, lilo will update the real boot sector, but the boot manager
will not realize it and will still run the old code stored in the
image-file. the old code of course has an invalid (old) map ...

the solution (for nt - i don't know bootmagic):

dd if=/dev/sda2 of=/c/bootsek.lin count=1

where /c is the mount-point of a fat-partition, where the nt-bootloader
resides. bootsek.lin is an arbitrary name choosen for the image file (you
would have to use the one, that already exists).

i hope, that this technique is also true for bootmagic.
good luck!

PS (to everybody): *please* make line-breaks ... it makes quoting so much
easier ...

Hi! I'm a .signature virus! Copy me into your ~/.signature, please!
Linux - the last service pack you'll ever need.

Reply to: