[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unresolved symbols in 8390.o and pcnet_cs

I answer this myself because I solved the problem. It looks like when I
did dselect with apt after installing the base system the pcmcia-package
was updated (this is annoying for pcmcia because this probably means
that this can happen again!) and these new modules did not work with my
old kernel. Everything is OK after compiling my own kernel and
pcmcia-modules from the source.


On Sun, 2 Apr 2000, Kari Ruohonen wrote:

> I made a fresh install (no update) of potato on my laptop. I have a D-link
> DFE-650 pcmcia ethernet card that has previously worked without problem
> (also earlier on slink). Now I have problems in getting it to
> work. /var/log/daemon.log tells that there are "unresolved symbols" in
> both 8390.o and pcnet_cs.o.
> There is no eth0 in ifconfig. The kernel is 2.2.14 from potato
> installation floppies. The pcmcia modem card I have works fine.
> 'insmod /lib/modules/2.2.14/pcmcia/8390.o' returns the following:
> unresolved symbol __kfree_skb_Rc5fdeebf
> unresolved symbol alloc_skb_R2baeae23
> unresolved symbol eth_type_trans_R0b43975d
> unresolved symbol skb_over_panic_Rf7c92034
> unresolved symbol ether_setup_R43debb67
> unresolved symbol netif_rx_Rf4daa2a7
> Kari
> -- 
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: