[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: man -k doesn't work

Ethan Benson wrote:

> >It turns out mandb is failing.  When I run mandb as root I get this:
> >
> >Processing manual pages under /usr/man...
> >Updating index cache for path `/usr/man'. Wait...mandb: can't create a
> >temporary filename: Permission denied
> >
> >I don't know enough about how mandb works (even after reading the
> >manpage and documentation) to know why this is happening.  Any ideas?
> check permissions on /tmp mandb is suid man so it does not have root
> privileges, however one annoying thing i have found is it creates a
> temp file but for some reason it gets owned by root so when it goes
> to delete it it gets a operation not permitted (because /tmp has the
> sticky bit) it seems to work better if you use sudo -u man mandb
> instead <shrug>

That worked.  Thanks so much!  I have really been missing "man -k".


Brian J. Stults
Doctoral Candidate
Department of Sociology
University at Albany - SUNY
Phone: (518) 442-4652  Fax: (518) 442-4936
Web: www.albany.edu/~bs7452

Reply to: