[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Re: New modules.conf + sound...



------Original Message------
From: Lee Maguire <lee@wetware.demon.co.uk>
To: <debian-user@lists.debian.org>
Sent: October 20, 1999 12:02:00 AM GMT
Subject: Re: New modules.conf + sound...



/*
it seems the new version of modutils now tries to pass io=0x220 directly to
sound.o (which it doesn't directly support)

Try commenting out the alias
#alias sound sb
and running update-modules, to see if the module loads
*/

Nope, no luck.  I still get:

----
Note: /etc/modules.conf is more recent than /lib/modules/2.2.10/modules.dep
/lib/modules/2.2.10/misc/sound.o: invalid parameter parm_io
/lib/modules/2.2.10/misc/sound.o: insmod /lib/modules/2.2.10/misc/sound.o
failed
/lib/modules/2.2.10/misc/sound.o: insmod sound failed
----

..from a modprobe sound.  Update-modules runs fine, as does depmod -a.  I
might also note that esd claims that /dev/dsp no longer exists.  I'd also
like to repeat my question regarding the gen_sound alias:

----
# Soundcard: alias for gen_sound needed!
alias           /dev/sound      gen_sound
----

What should I alias gen_sound to and how do I set it properly?  Unless I'm
losing it, I tried to set the gen_sound alias to sound and the entry
disappeared after I ran depmod and update-modules.

Once again, thanks in advance for any help that anyone can provide.

-Chris

P.S.  I've just noticed something very exasperating relating to my possible
insanity as stated in the previous paragraph: running update-modules wipes
out my changes!  Thus, my commenting out of alias sound sb was uncommented
and my alias gen-sound sound was similarly removed.  What is the correct way
to modify the /etc/modules.conf file?

__________________________________________________
FREE Email for ALL! Sign up at http://www.mail.com


Reply to: