[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: more info on dhcpcd problem

Seth, I have never been able to get dhcpcd to work. I installed dhclient and the only
success I've had, was with that. Perhaps you could try removing dhcpcd and installing
the package called dhcp-client-beta from the Debian installation CD's. Mind you, I am
still having trouble even though I created a setup which successfully connected, and
consistently for some time; now it doesn't, and nothing has changed in my setup. I
suspect that changes to my cable company's dhcp servers have been taking place, which
makes it very hard to diagnose problems.

Seth R Arnold wrote:

> Boy, I hate this... :)
> I think I mistyped my first submission to this mailing list. Here it is
> again, verbatim, save for fixing the errors I know I had in it.
> Hey gang, I desperatly need your help. I don't think my slink's dhcpcd is
> properly doing the dhcpdiscover.
> Specs:
> kernel 2.0.36, both custom and debian-default
> two 3c905b network cards (plan on ipmasq :)
> 3c59x.c driver from both debian-default and from donald becker's page
>         (Currently loading as a module.. btw, where to specify module
>         options?)
> Pentium II 266 oc to 300, on early motherboard
> I sure wish I could cut'n'paste the error messages. I ran
> /usr/sbin/dhcpcd -d eth0
> and after a few seconds of waiting, I get a message similar to:
> sendto (init): Operation not permitted
> running that command as root, and having it fail thusly is annoying. :)
> I have tried to run the dhcpcd with ifconfig eth0 up and ifconfig eth0 down.
> I am pretty sure it is eth0 because ifconfig shows that interface reciving
> thousands of packets -- but sending NONE.
> After running "/usr/sbin/dhcpcd eth0", it does not show up in ps aux, and
> "killall dhcpcd" gives "no processes killed".
> Should I load network driver into kernel, rather than as module? (keep in
> mind, TWO network cards.. :)
> Should eth0 be UP or DOWN before running dhcpcd? Should I ifconfig eth0 to a
> bogus IP before running dhcpcd? how about netmask?
> Please guys, I am very much sad at theloss of my internet... ;) (loss in the
> sense that when I was at home my windows machine had a modem... here, my
> linux machine has no modem, and no network access just yet... :( it hasn't
> worked in this configuration before... new network cards, new debian, etc..
> :)
> Thanks.
> On Tue, Aug 31, 1999 at 02:22:38AM -0700, Seth R Arnold wrote:
> > Oh yes -- an addition to my last email. Where I said the error message looks
> > like "xxx (init): cannot something.."
> >
> > the "xxx" should read: "sendto"
> >
> > I get the same error message when I try to ping places too. :)
> --
> Seth Arnold | http://www.willamette.edu/~sarnold/
> Hate spam? See http://maps.vix.com/rbl/ for help
> Hi! I'm a .signature virus! Copy me into
> your ~/.signature to help me spread!
> --
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: