[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrading perl - apache-ssl prob

Got the same trouble and have also put the pakages that require 5.005 on
hold, dselect doesn't complain anymore but... I have the following problem:

a/ perl -V
  Compiled at Jul  1 1999 02:04:21

b/ find /usr/lib/perl5/ -name strict.pm

c/ apache-ssl (non-US)
[Thu Jul  8 21:34:02 1999] [error] Can't locate strict.pm in @INC (@INC
contains: /usr/lib/perl5/i386-linux/5.004 /usr/lib/perl5
/usr/local/lib/site_perl/i386-linux /usr/local/lib/site_perl .
/etc/apache-ssl/ /etc/apache-ssl/lib/perl) at /usr/lib/perl5/Apache.pm line 3.
BEGIN failed--compilation aborted at /usr/lib/perl5/Apache.pm line 3.

d) I guess the libapache-mod-perl or whatever is not avare of the path
reorganisation in perl. Does anyone have an idea how I can work around the
problem (other than wait a week or so)?

Best regards,


On Mon, Jul 05, 1999 at 20:11 -0500, Christian Dysthe wrote:
> As far as I have been able to find out the best thing to do is to wait until
> the other packages has "caught up" with this Perl upgrade, at least a week or
> so. I tried to find out how to work arond this, but it didn't seem  worth
> while, so I will just put upgrades on hold for a week or so hoping the Perk
> dependencies are fixed by then.
> On 05-Jul-99 Max wrote:
> > Can anyone suggest how I can upgrade perl to 5.005 without dselect
> > forcing me to remove something like 150 packages?  It seems that
> > perl-5.005-base conflicts with perl but doesn't provide it.
> > Consequently, all the packages that depend on perl want to uninstall
> > themselves.  Any clues?
> > 
> > Please cc me on the replies.

Reply to: