[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Broken libtiff3g-dev

On Wed, Apr 28, 1999 at 10:28:21PM -0400, James Mastros wrote:
> Looking at libtiff3g-dev's postinst, it's trivial -- and it appears that it
> will die with error if /usr/sbin/dhelp_parse dosn't exist or "$1" !=
> configure.  I've filed a bug against libtiff3g-dev; it will probably be
> fixed shortly.

Hmm.  Ok, a new version has come out, and things are still looking
ugly.  When I tried to just let dselect/apt work it out, it still
didn't install.  I've given a try with dpkg again (this is with the
new version of libtiff3g-dev), and I get:

# dpkg -i libtiff3g-dev_3.4beta037-7_i386.deb
(Reading database ... 33019 files and directories currently installed.)
Preparing to replace libtiff3g-dev 3.4beta037-6 (using libtiff3g-dev_3.4beta037-7_i386.deb) ...
dpkg: warning - old pre-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
dpkg: error processing libtiff3g-dev_3.4beta037-7_i386.deb (--install):
 subprocess new pre-removal script returned error exit status 1
dpkg: error while cleaning up:
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:

I don't know what to do now.  It's not that I don't expect things to
be broken, but am I powerless to even get rid of this package now?  It
won't remove, or be upgraded.

Is there some source of information about how I could explore this
issue more?  For instance, how do I find out what the pre-remove
script does?  How do I find out what's broken?

BTW I have tried to use the man pages and internet references.  I
would have thought that --force-remove-reinstreq would help, but it

Ian Peters		"I never let schooling interfere with my education."
itp@gnu.org					-- Mark Twain

Reply to: