[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: serial troubles



Chea Prince wrote:
> 
> i suspected the modem too so tried a us robotics (usually have a gdc
> connected)...both behave the same.  seems to be related to warnings at
> bootup re: PCI ... there is a serial USB controller on IRQ 10 that is one
> of the PCI devices that isn't recognized (identified by number)... i tried
> disabling it and manually configuring /etc/rc.boot/0setserial but still
> get the same behavior.  i need info on this PCI bizness.  i read the
> PCI-HowTo but found nothing there of any use
> 
> the only debian cd i have is 2.0.27 (kernel)  think i'll try hamm
> if i can find a cd...maybe PCI problems have been eliminated
> 
> best--c
> 
> On 2 Jul
> 1998, Miquel van Smoorenburg wrote:
> 
> > In article <Pine.SUN.3.95.980702095628.4332D-100000@noel.pd.org>,
> > Chea Prince <cprince@noel.pd.org> wrote:
> > >
> > >have included serial support in the kernel and on bootup shows serial
> > >devices being assigned to /dev/cua0 /dev/cua1 and /dev/ttyS0
> > >/dev/ttyS1 but 'cat /proc/interrupts' shows no serial devices at
> > >IRQ 3 & 4.
> >
> > That's OK; the interrupts are only allocated when the port is actually
> > opened. You see, you can't share interrupts at the same time between
> > devices but 2 devices can use the same interrupt if they are not used
> > at the same time. That's why IRQs are only allocated when used.
> >
> > >can dialout fine from minicom but ppp script fails
> > >(can't initialize the modem).
> >
> > Smells like a modem problem. Maybe the modem is set to non-echo? Try using
> > the init string from minicom in the ppp script.
> >
> > Mike.
> > --
> >  Miquel van Smoorenburg | Our vision is to speed up time,
> >     miquels@cistron.nl  |   eventually eliminating it.
> >
> >


	I remember some PCI errors showing up during boot with older kernels
that were eliminated in later kernel versions(2.0.32+ ?), but, of
course, I can't tell whether this applies to your situation.

	What exacly does 'can't initialize the modem' mean?  I had a file
permission problem with the /etc/chatscript/provider script that caused
pppd to freeze when it tried to use the chatscript.  What does the end
of the ppp.log look like?  Use plog to see this.


-- 
Ed


--  
Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null


Reply to: