[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ipx_configure: socket: Invalid argument ?


I'm trying out Debian 1.3.1 because I've recently moved from
Yggdrasil to RedHat 4.2, and wasn't completely happy with RH.

Overall, the installation went well, though the dselect user
interface seems almost absurd, it's so bad.  (How does one find
out about Deity, and the plans for it?) 

I'm slowly trying to learn about network administration in
my home :-), with my old 486 and my new 586 and ethernet.
I've installed Debian on the 486.

I now have an NE2000 card configured correctly, detected during
boot up, and the ne kernel module installed.  But, after booting,
dmesg reports a couple of these errors:
	ipx_configure: socket: Invalid argument
which is also what I get if I later run ipx_configure manually.

These errors I think explain why pinging the machine itself
results in the error: `Network is unreachable'.  (I assume it's
because these errors stop /etc/init.d/network from being run.)
If I run "/etc/init.d/network start" manually, this problem
goes away. (* See below)
(I must say, this Debian idea is one of several good ideas.)

But, the socket problem remains.  I'm a bit lost about what
to do next.  A couple of oddities:  if I run modprobe -c
the output seems to have 2 contradictions:

1)	alias eth0 ne.o io=0x280 irq=11
	alias eth0 off

    which I read as saying ethernet is on and off; and

2)	alias net-fp-5 off
	alias net-fp-4 off
	alias net-fp-3 off
	alias net-fp-3 off
	alias net-fp-4 ipx
	alias net-fp-5 appletalk
	alias net-fp-5 off

Anyway, having fought my way past dselect (a worse UI is
hard to imagine), I expect it's quite possible something
got screwed up.

Any suggestions?  Maybe I should scrub the disc and re-install,
having a new attempt at the $#@&*^! deselect command.

A local Debian user (Terry Dawson) suggested that it might be
because the sysvinit or netbase packages weren't installed. These
seemed okay, but I installed them both again anyway.  dpkg -s
reports this:

genius# dpkg -s sysvinit; dpkg -s netbase
Package: sysvinit
Essential: yes
Status: install ok installed
Priority: required
Section: base
Installed-Size: 172
Maintainer: Miquel van Smoorenburg <miquels@cistron.nl>
Version: 2.71-2
Replaces: last, bsdutils (<= 2.0-2)
Pre-Depends: libc5 (>= 5.4.0-0)
Conflicts: last
 /etc/init.d/boot 6043411a35205ed214b8376d1703c543
 /etc/init.d/functions 0c0917923fade2b31aeba7ccff507b9d
 /etc/init.d/halt 68bc1f783330489603af45f7b2607220
 /etc/init.d/rc 60e77848ea246f436d6e15ff4c8aa6b0
 /etc/init.d/reboot 8a35f8a6172ce83901ec8959cfa00ded
 /etc/init.d/single 79ab06e4cb357207e0a2e0e12281478f
 /etc/init.d/skeleton a50a15ee6450c0d567054052af8d7bfc
Description: System-V like init.
 Init is the first program to run after your system is booted, and
 continues to run as process number 1 until your system halts. Init's
 job is to start other programs that are essential to the operation of
 your system. All processes are descended from init. For more information,
 see the manual page init(8).

Package: netbase
Status: install ok installed
Priority: standard
Section: net
Installed-Size: 520
Maintainer: Peter Tobias <tobias@et-inf.fho-emden.de>
Version: 2.13-1
Replaces: netstd (<< 2.00)
Depends: libc5 (>= 5.4.0-0)
Recommends: netstd (>= 2.00)
 /etc/init.d/netbase a2424d2c4eb454931ba68369ccdb6c7b
 /etc/cron.daily/netbase 5e0d3b20c37975fb27998c904c99828f
 /etc/gateways a7503b386fe803313210e201fa02e184
 /etc/protocols ffeb999437e9e69e03aa32991dfa487f
 /etc/services 0b7203dfa86920e7508d452dc9f93fe9
 /etc/hosts.allow 00c464628a18c520ff9b5aa47368dfb6
 /etc/hosts.deny 3c8c271d216386391a00f5376d353f5a
 /etc/rpc a5d6ea89a98449d83998b6b717215a03
Description: Basic TCP/IP networking binaries
 In order to make use of the network you need a few tools to
 configure it. This package contains all the necessary tools
 to configure the networking interfaces, to setup the routing
 tables and to start other services using the inetd server.

Is the `Conflicts: last' for sysvinit a worry?  What does it
mean?  I couldn't find anything via the info documentation.
(`info' is another program with an appalling UI.)

Hopefully yours,


  (*) I just tried this manual step today, and it failed.  Because
      the ethernet module wasn't installed.  I had to manually
	insmod 8390.o
	insmod ne.o io=0x280 irq=11

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: