[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: DEBIAN does not find my harddisk!!

On Thu, 8 Jan 1998, Nils Sandmann wrote:

> I've got an old 386 IBM PS/2 55 SX computer and when I start debian
> installation everything works quite well. (there are some error
> messages, but I don't know if they are relevant for my problem : 'PPA:
> unable to initialise controller at 0x308, error 1' and 'PS/2 ESDI:
> Attention error. interrupt status: EF'). After that it  is searching for
> the harddisk and it is doing something with it (you can hear it) and it
> then it displays the number of sectors and so on.. After that the kernel
> is loaded and the installation begins. Everything is fine until I want
> to create a swap disk. When the partion-program is loaded it says, that
> it can't find a harddisk. Why is this? It had already worked with the
> drive and it also told me the number of sectors, clusters and heads. If
> someone could help me I would be very thankful!

I have installed Debian on a PS/2, but it required a little fiddling around.
Here is what I wrote at the time

  (repost of previous message)

I am attempting a Debian install on an IBM PS/2 Model 70, with the standard
1.3 (might be 1.3.1) rescue disk.

The kernel recognises the IBM ESDI disks, but I had to do

mknod /dev/eda b 36 0
mknod /dev/eda1 b 36 1
mknod /dev/eda2 b 36 2

Also dinstall does not recognise /dev/eda as a local drive, so I have used the
second window to do the fdisk and mke2fs

The next problem is that fdisk -l does not recognise eda disks, even though
fdisk /dev/eda does work.

(This is being reported in the order I found it, there may be a better order)

I got round this by doing (in the other window)

fdisk /dev/eda >/tmp/fdisk
and then p, to list the partition table and q to quit.

I then edited the resulting /tmp/fdisk

With this I could enable swap, and eventually mount the root partition
(you have to keep recreating /tmp/fdisk because dinstall keeps overwriting it)

I have now reached the stage where it is installing the base set, so hopefully
everything will be OK from here.

	John Lines

 (end of repost of previous message)

Once the base set was installed everything else worked fine, though I have not
tried setting up X windows or anything else very fancy.

Note that there is a Linux on PS/2 page at http://glycerine.cetmm.uni.edu/mca
but that seems to be down at the moment. I seem to remember it was Slakware
based - but had usefull information for all versions of Linux.

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: