[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debian 1.3 on thinkpad 760xl

I recently bought the debian 1.3 cd's and an IBM thinkpad 760xl. The IBM came
with windows NT preinstalled. I have a 2.1Gig HD which I repartitioned into
two gig partitions using fips.exe. That worked fine.

My NT partition was booting fine (first partition) until I tried to install
linux. I made the boot-floppies via the method recommended by the Debian Linux
User's Guide (using rawrite2.exe to copy resc1440.exe, drivers1440.exe, and
the base-1.bin - 5.bin to seven dos formatted disks). I tried to boot the
install via disk drive and the boot-rescue and the boot: prompt came up. I hit
return and the system said

  loading root.bin ......
  loading linux ......

and then just hung there doing nothing. I waited about 5 minutes and then
decided that I had done something wrong but I didn't know what. So I copied
the install files (root.bin, linux, resc1440.bin, driv1440.bin, base-1.bin -
5.bin) to my d: partition (created via fips). I then booted the system with a
DOS 6.2 rescue floppy I had, changed to the d: partition and loaded the
install with loadlin (I had that on d:, too)

  loadlin linux root=/dev/ram initrd=root.bin

and the install began and continued along fine. During install I partitioned
my hardrive being careful not to touch the 1Gig Dos16 partition I had (which
housed NT). I then completed the install (installing no modules because I had
no idea which ones to load, and I had read in the HOWTO's that linux would
detected the IDE interface for the hard disk and the interface for the floppy
drive), created a boot floppy and rebooted using the boot-floppy and got this

  LILO loading linux

and nothing else, the machine just hung there. So I removed the boot-floppy,
and restarted the thinkpad and saw this

  error in partition tables

so now NT is gone. Ah, well so much for learning NT. So now I've tried several
attempts to install debian 1.3 and always the same problem. On reboot the
system hangs at

  LILO loading linux

So the two main things here

  1) I cannot install linux without first booting a DOS rescure disk and
loading the install using loadlin. If I just try the boot-rescue disk (with
resc1440.bin rawrite2'in to it) the system hangs after 
  loading linux ....

  2) After reboot (whether from floppy or hard drive, I've tried both) the
system hangs

  LILO loading linux

So I'm thinking that debian doesn't now how to read the IDE Hard Drive
interface and can't boot. 

So what do I do about this?

  - John Kloss

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: