[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian 1.3 on thinkpad 760xl

On Thu, 01 Jan 1998 04:35:24 EST, LKloss wrote:
> I recently bought the debian 1.3 cd's and an IBM thinkpad 760xl. The IBM came
> with windows NT preinstalled. I have a 2.1Gig HD which I repartitioned into
> two gig partitions using fips.exe. That worked fine.
> My NT partition was booting fine (first partition) until I tried to install
> linux. I made the boot-floppies via the method recommended by the Debian Linu
> User's Guide (using rawrite2.exe to copy resc1440.exe, drivers1440.exe, and
> the base-1.bin - 5.bin to seven dos formatted disks). I tried to boot the
> install via disk drive and the boot-rescue and the boot: prompt came up. I hi
> return and the system said

If your bios allows bootable cdroms, just stick it in and forget the 

> loading root.bin ......
> loading linux ......
> and then just hung there doing nothing. I waited about 5 minutes and then
> decided that I had done something wrong but I didn't know what. So I copied
> the install files (root.bin, linux, resc1440.bin, driv1440.bin, base-1.bin -
> 5.bin) to my d: partition (created via fips). I then booted the system with a
> DOS 6.2 rescue floppy I had, changed to the d: partition and loaded the
> install with loadlin (I had that on d:, too)
> using
> loadlin linux root=/dev/ram initrd=root.bin

In linux-land we refer to the "d:" as "/dev/hda2" (hd=ide, a=first ide 
port, first cable position, 2=second partition), assuming this 
information matches.

> and the install began and continued along fine. During install I partitioned
> my hardrive being careful not to touch the 1Gig Dos16 partition I had (which
> housed NT). I then completed the install (installing no modules because I had
What do you mean "installing no modules"?  I don't remember anything 
about installing modules.  I hope you installed the base packages and 
followed along in the manner prescribed in the installation doc 
The packaged kernel is very modular, and there's no choices to be made, 
either you get it or you don't.

If you haven't done so, you might want to read the Linux Gazzette 
article on getting started with debian, also at the above url and 
possibly this as well

Debian Linux User's Guide

> no idea which ones to load, and I had read in the HOWTO's that linux would
> detected the IDE interface for the hard disk and the interface for the floppy
> drive), created a boot floppy and rebooted using the boot-floppy and got this
> LILO loading linux
> and nothing else, the machine just hung there. So I removed the boot-floppy,
> and restarted the thinkpad and saw this 
> error in partition tables
> so now NT is gone. Ah, well so much for learning NT. So now I've tried several

I wouldn't be so quick to make that conclusion.  Maybe you just 
overwrote the mbr.  A dos "fdisk /mbr" might fix that.  Or perhaps the 
wrong partition is marked active.  The error could even be on the Linux 
side.  Lilo has some advanced documentation in /usr/doc/lilo which 
might prove helpful (warning: perhaps after confusing you further).

> attempts to install debian 1.3 and always the same problem. On reboot the
> system hangs at
> LILO loading linux

If you can boot from your boot disks, then you should be able to get in 
and reconfigure lilo.  I thought you were supposed to do this, i.e.: it 
was not optional.
> So the two main things here
> 1) I cannot install linux without first booting a DOS rescure disk and
> loading the install using loadlin. If I just try the boot-rescue disk (with
> resc1440.bin rawrite2'in to it) the system hangs after 
> loading linux ....

I don't have a working knowledge of loadlin (though I understand what 
it does), so I'm a little unclear about what exactly is happening here, 
but it seems to me the only problem with linux booting is that lilo 
isn't configured properly, and possibly some inconsistencies in fdisk.

You also didn't indicate anything which would lead me to believe nt was 
damaged in any way, only that there was a glitch during install.  Where 
did you install lilo?  If you install lilo on the linux "/" ("root") 
partition, then lilo won't touch your master boot record and you can 
boot linux by setting the active partition to your linux partition to 
boot linux (lilo) or your nt partition to boot nt (ntloader).  I do 
this to prevent mbr mangling.  Of course, if your mbr was overwritten, 
you'll need to fix that, and a dos "fdisk /mbr" is probably the easiest 
and safest way, if the backup copy still exists.

> 2) After reboot (whether from floppy or hard drive, I've tried both) the
> system hangs
> at 
> LILO loading linux
> So I'm thinking that debian doesn't now how to read the IDE Hard Drive
> interface and can't boot. 

I doubt that.  Try reinstalling and pay attention to the part where you 
install the base packages, ... , also look at your partition table to 
see which parition is marked active (bootable, it will have a * by it) 
using fdisk.  After install, loot at /etc/lilo.conf and confirm that 
the information is correct (there's a man page for lilo.conf).  If you 
make any changes to lilo.conf, always re-run lilo to update.

Here are some linux laptop urls you might find helpful.  You might also 
need some lilo boot params to boot the thinkpad, I wouldn't know.

Linux On Portables

Linux on Laptops NO Intel

X and Linux on Notebooks

David Stern


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: