[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: pppd complains link isn't 8-bit clean!

Mark Phillips wrote:
> Hi,
> A friend and I have been having problems getting ppp to work on his
> laptop.  Everything works with the chat script until just after ppp is
> engaged.  Then it complains as follows.
> pppd Serial connection established
> Using interface ppp0
> Connect:ppp0 <-> /dev/ttyS1
> LCP: timeout sending Config-Requests
> Connection terminated.
> Receive serial link is not 8-bit clean:
> Problem: all has bit 7 set to 0
> I've tried connecting with ppp from windows 95 on the same machine with
> the same modem etc, and it all works fine, so it would seem the problem is
> something to do with the debian setup.  The only thing I can think of is
> interrupts, but I have looked at /proc/interrupts and it seems okay - but
> perhaps this doesn't tell the whole story???
> Any help would be much appreciated.

Look at your chat script. Test its workings by using minicom, cu, 
seyon, or some other terminal program to "manually" dial in. Just
because you get 'Connect: ppp0 <-> /dev/ttyS1' doesn't mean that
your connect script worked. It simply means that your connect script
*thinks* that it worked. Think about what the error message is telling
you: pppd never received an LCP packet which infers that ppp was
never started and also that 'all has bit 7 set to 0'. Now, what sort
of characters always have bit 7 set to 0. Answer: printable ASCII
characters (as well as a few unprintable ones). This should generally
suggest to you that the system on the other end is still sending you
some kind of prompt. Check it out, this is most likely the solution.

Jens B. Jorgensen

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: