[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Matlab5

Steve Hsieh writes:
>Sounds like you need to include some of the libraries that matlab was
>compiled against inside the $MATLAB/sys/lnx86 directory -- the libstdc++
>library that comes with debian doesn't work with matlab 5.1 and will
>produce the error you write below.  Here's the libs we use for a working
>matlab on Debian... You can get them from mathwork's ftp site, or
>alternately, you can email me privately and I can send them to you.

Hmmm.  I am using the libc++ that is in libg++_2.7.2.1-8.deb and am
having no problems.  This is what ldd is giving me on Matlab

#ldd $MATLAB/bin/lnx86/matlab
        libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6
        libdl.so.1 => /lib/libdl.so.1
        libg++.so.27 => /usr/lib/libg++.so.27
        libstdc++.so.27 => /usr/lib/libstdc++.so.27
        libm.so.5 => /lib/libm.so.5
        libc.so.5 => /lib/libc.so.5
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6

Mechanical Engineering				    servis@purdue.edu
Purdue University		    http://www.ecn.purdue.edu/~servis

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: