[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

End of device [was Re: kernel messages]

On Sun, Oct 26, 1997 at 09:14:56PM -0500, Thalia L. Hooker wrote:
> Hi,
> I was just noticed in my log files that I have these messages in my
> /var/adm/kern.log:
> attempt to access beyond end of device
> 03:02: rw=0, want 707406379, limit 1433376
> This message is repeated several times and ultimately the computer locks up.
> Does someone have an idea what is causing these messages?
> btw, the only process being run by a user at this point is myself trying to
> build a new kernel.

I don't know if this is related or not, but the last time I tried to
make a partition on my disk, I got hundreds of consecutive seek errors
from mkfs.  This is on a 1.3G Western Digital IDE that has never had any
bad sectors.  I had just deleted some partitions to resize them, and the
last new partition failed to build.  (I think there was some free space
at the end of the disk before, and this time around I tried to use up
all the space.)

This was a couple months ago.  I just chalked it up to either my disk
really is going bad (although it's remained reliable ever since), or
else e2fsck really is overrunning the end of the disk for some reason,
or cfdisk reported more blocks than were actually there.  This is with a
2.0.28 kernel.  I just gave up trying to use that portion of the disk.

************** MICHAEL SCOTT ORR <mso@jimpick.com> *****************
*    *  1405 NE 56th Street, Seattle, WA 98105 USA     *   English *
*    *  Tel: +1 (206) 522-9627, fax: 328-6209          *    Russki * 
*    *                                                 * Esperanto *
***************** (Insert silly quote here) ************************

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: