[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Boot Problems



In article <199710031550.KAA07671@ns2.icon.net> Russ Cook wrote:
[Klippa, klapp, kluppit.]

: I have built a custom kernel (2.0.30) to remove unnecessary file system
: support, and add IP Masquerading. I've followed the instructions in
: /usr/src/linux/README.  I've made a boot floppy with the new kernel, and I
: ran "rdev /dev/fd0 /dev/sdb6" where sdb6 is the Linux partition on my
: second SCSI drive.  I then ran "rdev /dev/fd0" to verify the floppy was
: pointing to /dev/sdb6, and it reported correctly.  When I reboot the
: machine from the floppy, a screen of preliminary configuration info is
: displayed, then I get a kernel panic with the message: VFS: can't mount
: boot device 8:16.

This is in hex. In decimal it becomes 8, 22, which is sdb6, just as
you have said you have set it to.

Perhaps you said no to some neccessary config options, which you
didn't think you'd be needing?

I think that you need e. g. CONFIG_BLK_DEV_RAM and
CONFIG_BLK_DEV_INITRD set to "y". Perhaps somebody else care to
comment?

: I've been reading the messages regarding 16 partitions per SCSI drive.  I
: specifically configured (using rdev) to boot to /dev/sdb6.  I don't yet
: understand all about the major/minor stuff.  I plan to read more this
: weekend.  When I run lilo on my kernel on the hard drive, and reboot, I get
: the same message as when I boot from floppy. 

As long as you don't have more than 11 extended partitions there's
nothing to worry about (more than the usual things).

: The originally installed kernel (from the 2 CD set) boots fine.  I have
: remembered to set /vmlinuz to point to the correct kernel, and I ran lilo
: to update the System.map.

The package kernel-package is a very neat one if you want to rebuild
your kernel.


Hth,

							MartinS


--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .


Reply to: